Chapter 5. GIS and Decision-Making

GIS professionals are involved in the use and application of GIS in a wide range of areas, including government, business, and planning. So far, it has been introduced that a GIS consists of computer software, hardware, and peripherals that visualize, manage, manipulate, and analyze geographically referenced data. It can be a tool for performing an analysis of spatial interactions between static and dynamic entities in the environment. Technically, GIS is characterized by three unique but interrelated strengths.

1. Spatial data management.
2. Interactive visualization.
3. Spatial analysis and decision making support.

You have been exposed to the first two strengths in the previous chapters. In this chapter, we will introduce you to the third strength that constitutes the foundation for spatial decision support system.

The integration of GIS with the decision making process marks the cornerstone for applying machines to support human problem solving. Let’s take the example of a data analysis to support a recruitment of school-age children for a community agency. Although the census data of the children population is available, along with the household income and other social-economic characteristics, it is still difficult to provide recommendations for where to better recruit the children. A GIS map translating the same information can give an intuitive idea to solve such particular case (Figure 5.1).

![Figure 5.1. Example of GIS map as a support to decision-making. (Source: High Scope Foundation, 1998)]
This chapter will continue the introduction of basic concepts and techniques of GIS in solving real-world problems. This chapter contains four sections:

**Section 1:** Spatial analysis and decision making support, which introduces the importance of GIS spatial analysis.

**Section 2:** Basics of spatial analysis, which focuses on basic concepts, general steps, and types of spatial analysis.

**Section 3:** ArcView solutions for spatial analysis, which introduces how a desktop GIS handles spatial analysis, and how spatial analysis functions can be enhanced in a desktop GIS. Several exercises are designed to help you get familiar with spatial analysis in the context of answering some simple questions.

**Section 4:** Exercises, which provides hands-on experience with spatial analysis in various settings.

### 1. Spatial Analysis And Decision Making Support

Decision-making from spatial analysis involves four important considerations:

- An objective (as opposed to subjective) understanding of the reality; the potential problem(s) must be clearly formulated and specified from the beginning of the process.
- Some specific guideline(s) to base the future decision upon.
- The availability of a data set for a modeling/quantitative analysis.
- An awareness of the social and environmental constraints.

These considerations involve some interaction and communication between agencies, administrators, specialists, and even machines/computers. The GIS systems provide powerful tools to tackle every phase of this process (Figure 5.2), which gives the decision-makers the best alternatives for setting policies and strategies.

![GIS and spatial decision support](Source: ESRI, 1997)
2. Basics of Spatial Analysis

Geographic analysis allows the study of real-world processes (which then can be simplified conceptually, qualitatively, quantitatively, or for administrative and political purposes) by developing and applying models. A GIS provides valuable tools that can be combined in meaningful sequences to develop new models. Such models may reveal some underlying trends in the geographic data and may provide new valuable information; they may bring to the user’s attention new or previously unnoticed relationships within and between data sets, increasing the understanding of the real world.

2.1 General steps for performing Spatial Analysis

Before starting any GIS application or project, two key-questions must be addressed: *why* and *how*.

*Why* gives the motivation for using a GIS system, indicating that you need to know the problem you are trying to solve. You need to assess the problem at hand and establish an objective.

*How* is organizing the needed logical steps and procedures to solve the problem. Spending sufficient time in figuring out the right steps to solve a problem is a necessity to GIS users. You should try to avoid launching GIS operations before knowing what outcomes will be generated. Though it is not trivial for a beginner, you need to think through the process, which will lead to the right solutions. It is imperative that you should know the following issues:

- The problem(s).
- The data.
- Domain specific problem-solving rules.
- Available GIS functions (supported by the GIS software you are using).

Though there is no fixed way of organizing a GIS project, the following steps are recommend by the majority of GIS professionals (ESRI, 1995, p.8-2).

**Step 1:** Establish the objectives and criteria for the analysis.
**Step 2:** Outline the procedures step by step based on the expert knowledge of the problem to solve.
**Step 3:** Define the right GIS operations (commands), and find the needed spatial and tabular data, for the problem-solving procedures.
**Step 4:** Prepare the data for spatial operations.
**Step 5:** Perform the spatial operations.
**Step 6:** Prepare the derived data for tabular analysis.
**Step 7:** Perform the tabular analysis.
**Step 8:** Evaluate and interpret the results.
Step 9: Refine the analysis as needed.

2.2 Types of Spatial Analysis

Spatial analysis includes a wide variety of GIS functions, ranging from simple topological operations to more complex modeling or advanced statistical operations. However, topological operations account for the majority of spatial analysis performed in ordinary GIS applications.

Some topological operations are frequently used; we have organized them into four principal groups.

- **Proximity analysis**, such as, buffer, near, and point distance commands in Arc/Info;
  Used when you need information about the area surrounding existing features.
- **Boundary operations**, including “append”, “clip”, “erase”, “map join”, “split”, “update” functions;
  Used when the information you need can be selected by its geographic location.
- **Logical operations**, such as “reselect”, “dissolve/merge”, “eliminate”;
  Used when the information you want can be selected by its descriptive attributes.
- **Spatial joins**, including, identity, intersect, union (all of these consisting of GIS Overlay functionality);
  Used when you need to add polygon information from other geographic features to your current database.

3. Examples of Spatial Analysis

3.1 Buffer

The buffer operation is used to generate buffer zones around geographic features. You can create buffers around points, lines, and polygons (Figure 5.3).

![Figure 5.3. Buffer operation. (Source: Arc Online Help)](image)

For instance, if the line represents a river, the buffered zone may have been used to identify possible flooding area. If the point is a polluted site, the buffered zone may depict the area affected by the pollution. The interpretation of the buffer operation depends on the subject of your interest.
3.2 Overlay

The overlay spatial operation has been the heart of GIS spatial analysis. By the way, it has been used to symbolize GIS for many years.

Overlay combines spatial information from multiple data layers to show composite effects or hidden interactions between multiple factors. Let's consider the following Figure 5.5, showing the result of an analysis of land suitability for different purposes. Four types of possible landuse have been considered in this example.

Type 1: Open land (land conserved) – the first two characters (OP) in the legend.
Type 2: Industrial – the second pair of characters (IN).
Type 3: Commercial – the third pair of characters (CO).
Type 4: Residential – the last pair of characters (RE).
The XX annotation is attributed to lands that do not fit into any of these given types.

The purpose, in this example, is to decide about the suitability of an area for a specific land use. This logical reasoning is built on the GIS operation overlay. In general, the analysis involves three main steps as follow.

**Step 1:** Overlay all data layers that are pertinent to the land suitability. In this example, there are seven data layers as also shown in the following attribute table:
- Distance from a communication line – COMMBUF.
- Current land use – DEVELOP.
- Floodplain – FLOOD.
- Distance from a highway – HGWBUFF.
- Distance from a sewer line – SEWERBUF.
- Drainage – DRAINAGE.
- Slope – SLOPE.

![Attributes of Suitable.shp](image)

Figure 5.6. Data layers used in the suitability overlay operation

After performing the overlay operation, you see peculiar lines interwoven to form irregular polygons in Figure 5.5. The GIS system also creates a field (item, or column) called AREA (in this case we renamed it LAND-ACRE), which reports the calculated area for each piece of polygon intersected by the feature boundary lines of all seven data layers (Figure 5.6).

**Step 2:** Formulate analysis criteria for various types of land suitability.
For instance, we decide that for a land to be suitable for residential buildings, it must meet the following criteria.
- Currently an open space.
- Not located in a floodplain.
- Within 2,640 feet from an existing sewer line.
• Landscape slope cannot exceed 5%.

A similar approach can be taken to define suitability for other land uses.

**Step 3:** Apply the criteria to your data sets (through query or reselect) to identify the suitability for each piece of land (see Column, SUIT_CLAS in Figure 5.6).

### 3.2.1 How Overlay Works

An overlay operation performs geometric intersection between features in two data layers.

Suppose we have two data layers, Floodplain (Figure 5.7a) and Soil (Figure 5.7b). When performing an overlay, the GIS system geometrically intersects the feature boundaries in one layer with that of another feature in a second layer, generating the intersected polygons (Figure 5.7c).

![Figure 5.7a. Floodplain data layer](image1)

![Figure 5.7b. Soil data layer](image2)

It can be of interest to know the geometric relationship between the intersected layer and the two source layers. This relationship is recorded in a newly generated attribute table (Figure 5.7d). This table contains the same attributes as those from the source layer attribute tables. For example, the items Soil and S_Code are inherited from the soil data layer; while the items Flood and F_Code are from the floodplain data layer. When you list these attributes, you will see the relationship.

A common practice for looking quickly into the relationship is to create a new field (such as Composite in Figure 5.7d) with some symbolic designation that immediately tells the relationship. For instance, the symbol po_FL indicates the combination of poor soil with floodplain, which is not suitable for land development.
4. Arcview Solutions for Spatial Analysis

ArcView is a desktop mapping GIS application that provides a wide range of possibilities for analytical functions. It also handles spatial relationships in a simplified way, through spatial query.

4.1 Theme-on-theme selection

ArcView provides the ability to select the features of one or more themes using the features of another theme. Selecting features in this way is one of the spatial analysis methods you can use to solve problems that involve issues of proximity, adjacency, and containment. This process is called **theme-on-theme selection**.
Theme-on-theme selection involves at least two themes (Figure 5.8).

- **Target theme** – The theme whose features are to be selected. There may be multiple target themes (usually active themes).
- **Selector theme** – The theme whose features are used for selection, usually choosing from the select-by-theme browser.

The theme-on-theme selection is launched under the item **Select By Theme** of the **Theme** menu (Figure 5.9), giving the six types of spatial relations supported by ArcView.
**Are Completely Within** - Selects features in the target themes if they fall completely within one or more of the selector theme’s features.

**Completely Contain** - Selects features in the target themes that completely contain one or more of the selector theme’s features.

**Have their Center In** - Selects features in the target themes if their center falls inside the selector theme’s features.

**Contain the Center Of** - Selects features in the target themes that contain the center of one or more of the selector theme’s features

**Intersect** - Selects features in the target themes that intersect the features in the target. Intersection implies that at least one point is common to both the selector and the target or one of them is completely within the other. If the selector and target are the same, Intersect will select adjacent features.

**Are Within Distance Of** - Selects features in the target themes that are within a specified distance of the selector theme’s features.

### 4.2 Spatial Join

Spatial join is another spatial analysis method (see paragraph 2.2 of this Chapter). It is set to define possible relationship(s) among points and polygons (defined in paragraph 1 of Chapter 2).

A **spatial join** functions much like an attribute join on two tables, but the difference resides in that it uses the **Shape** fields to join the attribute tables, whereas the table join uses any other common field to the two tables (see Exercise 4C of Chapter 4). ArcView supports the following spatial joins.

- Point to Point (proximity)
- Point to Line (proximity)
- Point in Polygon (inclusion)
- Line to Point (proximity)
- Line in Line (intersection)
- Line in Polygon (inclusion)
- Polygon in Polygon (inclusion)

**Spatial queries** can also be used to define some specific relationship between themes; for example, to identify students in a particular school district area, to locate zip codes within school districts, to trace bus routes within school districts, or a variety of other possibilities related to spatial data (Ibid). In a spatial join, three types of spatial relations are used. Depending on the theme types, you will use different spatial relations. For Point in Polygon, Line in Polygon, and Polygon in Polygon joins, you will use the “Are Completely Within” spatial relation type. For example, assume you want to join two polygon themes, one for zip codes, and one for school districts. The zip codes table is the destination attribute table. The only zip codes that receive school district attributes following the spatial join are those that are contained entirely within a single school district area.
A Line in Line spatial join uses “Intersect” as the spatial relation type, whereas Point to Point, Point to Line, and Line to Point spatial joins use the “Nearest” spatial operator. In joins that use the “Nearest” relation type, a Distance field is added to the joined table. The Distance field contains the distance measured in map units between the joined features.

Warning: Re-opening a theme with a spatial join in a project can cause a fatal error.

To prevent such occurring, it is necessary to remove all spatial joins from a project before saving. To preserve the result of the spatial join for future use, save the target theme as a new shapefile before removing the spatial join. Add the shapefile to the view as a new theme, and then save the project.

There are two types of spatial join.

1. A spatial join between two point themes is shown in Figure 10. This join creates a DISTANCE field in the joint table (Figure 11).

Figure 10. Spatial join for two point themes.
2. Spatial join between point and polygon themes (Figure 12). This join adds the polygon attributes onto the point theme attribute table, to identify an inclusion relationship for the point features (Figure 13).
Figure 13. Results of a spatial join between point and polygon themes.

5. Third Party Developed Spatial Analysis Tools

ArcView is very user-friendly, but is limited by lack of full-fledged spatial analysis functions. Many users (including government agencies and GIS engineering/consulting firms) are developing add-ons to ArcView. With the generous mind of supporting GIS communities, some users provide public access to their customized tools.

XTools is a very successful story. Mr. Mike DeLaune of the Oregon Forestry Department has produced an excellent ArcView extension called XTools, which allows easy editing of vector data. Among other things, it also allows the combining of multi-part shapes and combining of themes (Figure 14). The extension can be downloaded from: http://www.odf.state.or.us/sfgis/
Exercises

5A. Point to Point Relationships

(Finding 307 pollution sites near a drinking water source)

Step 1: Start ArcView and open an existing project.

From the File menu, choose Open Project. Move to the directory Your Drive:\Chapter 5\ and double click the project ex05a.apr.

When the project opens, you see a view containing two themes labeled: Detroit Act307 Sites and Dws.shp.

NOTE: The drinking water sources theme is produced from a fictional data set.

Step 2: Perform finding operation

Click the Detroit Act307 Sites theme in the table of contents to make it active, meanwhile make sure others are not in active status.
From Theme menu, choose **Select by Theme**.

In the **Select by Theme** dialog box, set the bar “Select features of active themes that” as Are Within Distance Of; the bar “the selected features of” as Drinking Water Sources; the bar “Selection distance” as 5000;

Then click on the **New Set** button.

Now, watch carefully the changes of the view. Is one Act 307 site selected? Change the value in **Selection distance**, and repeat the analysis. Notice the changes on the GIS map.
Step 3: Save and close the project

Make the Project window active.
From the File menu, choose Save Project As.
Give a name to your project.
Move to your personal directory and save the project.
From the File menu, choose Close Project.

5B. Point to Line Relationships

Step 1: Start ArcView and open an existing project

From the File menu, choose Open Project. Move to the directory Your Drive:\Chapter 5\ and double click the project ex05b.apr.

When the project opens, you see a view containing three themes labeled as: Shore.shp, Act307.shp, and Detroit.shp.

Step 2: Perform finding operation

In the Table of Contents, click on Act307.shp to make it the only active theme.

From Theme menu, choose Select by Theme.
In the **Select by Theme** dialog box, set the bar “Select features of active themes that” as Are Within Distance Of; the bar “the selected features of” as Shore.shp; the bar “Selection distance” as 3000.

Then click on the **New Set** button.

Now, watch carefully the changes of the view. Are some Act307.shp sites selected? Change the value in **Selection distance**, and repeat the analysis. Each time, notice the changes on the GIS map.

**Step 3: Save and close the project**

Make the **Project** window active.  
From the **File** menu, choose **Save Project As**.  
Give a name to your project.  
Move to your personal directory and save the project.  
From the **File** menu, choose **Close Project**.

**5C. Polygon to Line relationships**

**Step 1: Start ArcView and open an existing project**

From the **File** menu, choose **Open Project**. Move to the directory Your Drive:\Chapter 5\ and double click the project **ex05c.apr**.

When the project opens, you see a view containing two themes labeled as: Town.shp and Hwy-sel.shp.

**NOTE:** In our example, we simply assume that this portion of highway represents a given utility-line serving some townships, of which we can get the spatial data.
**Step 2: Perform finding operation**

In the Table of Contents, click on Hwy-sel.shp, to make it the only active theme.

Press the **Query Builder** button.

In the Query Builder window, double click **Roadhwy_id** in the Field window, then double click on “=” button, then double click **100** in the Value window. These operations will build an expression statement as “Roadhwy_id = 100”.

Then, press the button **New Set**. Now, the highway, which ID code is 100, has been selected, and highlighted in the theme.

Make the **Town.shp** theme active.

From **Theme** menu, choose **Select by Theme**.
In the Select by Theme dialog box, set the bar “Select features of active themes that” as Intersect; the bar “the selected features of” as Hwy-sel.shp; then press the New Set button.

Now, watch carefully the changes of the view. You will see that several townships have been selected, and highlighted. You can, either identify them on the map, or from the “Attributes of Town” table.

**Step 3: Save and close the project**

Make the Project window active.
From the File menu, choose Save Project As.
Give a name to your project.
Move to your personal directory and save the project.
From the File menu, choose Close Project.

5D. Finding schools within a city

**Step 1: Start ArcView and open an existing project**

From the File menu, choose Open Project. Move to the directory Your Drive:\Chapter 5\ and double click the project ex05d.apr.

When the project opens, you see a view containing two themes, labeled as Schools.shp and Town.shp.

**Step 2: Perform finding operation**

In the Table of Contents, click on Town.shp to make it the only active theme.

Press the Query Builder button

In the Query Builder window, double click [Tname] in the Fields window, then double click “=” button, then double click “DETROIT” in the Values window. These operations will build an expression statement as [Tname] = “DETROIT”. Then, press the button New Set. Now, the Detroit town has been selected, it will be highlighted in the theme.
Click the Schools.shp theme in the table of contents to make it active.

From Theme menu choose Select by Theme. A dialog box will pop up.

In the Select by Theme dialog box, set the bar “Select features of active themes that” as Are Completely Within; the bar “the selected features of” as Town.shp; Then press the New Set button.

Now, watch carefully the changes of the view. You will see that several schools, which are located in Detroit town, have been selected and highlighted.

**Step 3: Summary of schools by towns**

Suppose you want to know the number of all schools in a given township. You need first to create an attribute table that contains a field for “Schools” and another field for “Town”. We get such needed table by performing a spatial join
between the attribute tables corresponding to the actual themes. With the resulting table, you then summarize as in Step 3 of Exercise 4B.

- With the Towns.shp theme active, open the table **Attributes of Town.shp**. Click on the field **Shape**.

With the Schools.shp theme active, open now the table **Attributes of Schools.shp**. Click on the field **Shape**.

Click on the **Join** button to create a spatial join between the two tables. A single table is created, containing all the fields from the two previously separate tables.

- Keep the **Schools.shp** theme as the active one.

In the “joined” table, click on the **Tname** field to make it active.

Click the **Summarize** button to open the **Summary Table Definition** dialog box.

In the **Save As** input box, change the pathname to that of your personal directory, such as `c:\yourname\sum1.dbf`. Set Field: as Shape, and Summarize by: as Merge.

Click **OK**

A new table, called `sum1.dbf`, displays. It shows you the number (Count) of schools in each township area.

<table>
<thead>
<tr>
<th>Township</th>
<th>Count</th>
</tr>
</thead>
<tbody>
<tr>
<td>BLOOMFIELD HILLS</td>
<td>1</td>
</tr>
<tr>
<td>BLOOMFIELD Twp</td>
<td>8</td>
</tr>
<tr>
<td>CANTON Twp</td>
<td>3</td>
</tr>
<tr>
<td>COMMERCE Twp</td>
<td>1</td>
</tr>
<tr>
<td>DEARBORN</td>
<td>7</td>
</tr>
<tr>
<td>DEARBORN HEIGHTS</td>
<td>2</td>
</tr>
<tr>
<td>DETROIT</td>
<td>34</td>
</tr>
<tr>
<td>FARMINGTON</td>
<td>1</td>
</tr>
<tr>
<td>FARMINGTON HILLS</td>
<td>2</td>
</tr>
<tr>
<td>FERNDALE</td>
<td>2</td>
</tr>
<tr>
<td>GARDEN CITY</td>
<td>1</td>
</tr>
<tr>
<td>GROSSE POINTE FARMS</td>
<td>2</td>
</tr>
<tr>
<td>GROSSE POINTE PARK</td>
<td>1</td>
</tr>
</tbody>
</table>
**Important Note**: It is important to REMOVE ALL JOINS in the attribute table before you continue.
Make the Attributes of Schools.shp table active. Click on Remove All Joins, under the Table menu.

**Step 4: Legend the towns theme by the total number of schools**

In this step, you will put on the map the number of schools as a legend for each township polygon. (The map in the View document will show the numbers of school in each township polygon, allowing a quick visual of the existing situation in the area).

Keep the sum1.dbf table from the previous Step 3 open. Click on the Tname field to make it active.

Open the table Attributes of Town.shp. Click on the Tname field to make it active.

Join the two tables.

Make the Towns.shp theme active.

Under the Theme menu, select Auto Label. Make the selections in the “Auto-label: Town.shp” window as shown in the following figure:

![Auto-label: Town.shp window](image)

(Label field as: Count
Only check “Find Best Label Placement”, “Allow Overlapping Labels”, and “Scale Labels”.)

Click on OK.
**Step 5: Save and close the project**

Make the Project window active. From the File menu, choose Save Project As. Give a name to your project.

Move to your personal directory and save the project. From the File menu, choose Close Project.
Bibliography

Environmental Systems Research Institute, 1998. ARC/INFO Online Help.

High Scope Foundation, 1998. Distribution of Children Ages 3-4 Not in Pre-Primary School.